Elegant Themes Blog

Stay up to date with our most recent news and updates

WordPress 3.5 Has Been Released

Posted on December 11 by in General News | 62 comments

WordPress 3.5 Has Been Released

WordPress 3.5, aka “WordPress Elvin,” was released today. You will be happy to know that we have already been testing and updating our themes based on each 3.5 RC, and all themes should already be compatible with the new version of WordPress. Our plugins have also been tested and updated, so be sure to upgrade the Elegant Builder to version 2.2 to avoid any potential problems. Before updating, just make sure that you are using the latest version of your theme and that you follow the WordPress best practices for updates. This includes making a backup of your installation and disabling your plugins before hitting that update button!

For more information on 3.5, swing by the WordPress.org Blog.

62 Comments

  1. Thanks for the heads-up – I hadn’t heard. I was sorry I upgraded when the last update went live though. Will be interesting to see if anyone has any problems with it! Not the themes of course – the update itself. When I emailed my host they said not to update immediately next time but to wait a couple of weeks.

    • I’ve checked 3.5 and it seems legit. I haven’t had any problems with any of my upgrades. You should be good to go.

    • I upgraded one of my sites and the plugins were not compatible so I had to downgrade. 8-(

  2. Whenever a new version of WordPress is released, I’m both happy and sad. Sad because I am suddenly worried that will my themes break if I update. Your post assured me that I can update without any worries. Thanks again ET!

  3. Hope blogging will be easier and more fun :)

  4. I always wait 14 days before updating to be sure the New WordPress has no admin bugs. The themes never broke my WordPress while updating, even when I use themes from 2 years and older. When my WordPress breaks its usually a plugin problem.

  5. Maybe I will wait for a few days to make sure that themes and plugins developers release package to make their products compatible with WordPress 3.5. I am scared of messing up my site with the new update immediately.

    • I agree. I always do the same except with my sandbox sites. Those are autocronned every hour (since they’re in dev), so I can always just drop the old version when it’s time to get it out of development if need be. But yes, ALWAYS wait for plugin devs and theme devs to update before jumping on new WP update. Especially since 9/10 a site will break on update due to a plugin not being 100% compatible with the new update.

      • Pure scaremongering. There is absolutely no way that 90% of WordPress installations will break each time WordPress is updated. Please people, follow best practice but don’t worry about statements like this.

  6. I’m having some problems with the elegant builder plugin with WP 3.5. I am not sure if this is a WP 3.5 incompatibility problems, or it is conflicting with some other plugin. I will try it again tomorrow with a clean WP 3.5 installation. This is the worst thing about WP. Plugins not playing nice with each other, and constant security problems, mostly due to plugins. I always clone a site and test it on a development server before applying any upgrades, whether it’s the core, plugins or themes. It is a non stop research and testing…

    Also note that, the developers in their blog are talking about some reported bugs, and many reports about plugins not working with 3.5. 3.5.1 might be coming our way much sooner than we thought.

    Is it me or WP 3.5 runs faster than v3.4.2? Nobody has talked about this… so it must be me!

    • Please make sure that you are using the latest version of the Elegant Builder, version 2.2, which has been tested and updated for WP 3.5. The plugin was updated a week ago to address these upcoming issues.

      • How do you upgrade to 2.2 builder? Why isn’t it set up like how you would upgrade any other plugin? I am hoping it will fix my empty module issues. as I show in this screencast. http://www.youtube.com/watch?v=6__uNQRNodk

        • If you need help with something, please open a thread in our support forums so that our team can assist you.

  7. Everything works fine, but the elegantbuilder pluggin does not ;-)

    • Please be sure that you are using the latest version of the Elegant Builder, version 2.2, which has been tested and updated for WP 3.5. There will be problems if you do not keep your plugins up to date. The plugin was updated a week ago to address these upcoming issues.

      • thank you :-)
        it works now

  8. I’ll just confirm what others have posted. I’ll wait. I really don’t see the rush to update unless it’s patching some bad security issue or I “must have” the new features available. From what I see in this update it’s nothing I need immediately.

  9. thank you for this information. not currently want to upgrade, wait for the reviews on WP 3.5

  10. i am curious abotur the updates. haven’t checked it out until now!

  11. Greetings, Elegant Themes team,

    Your themes are the most flexible and good-looking around, and I’m been using them for a while.

    I’m building a site for a client right now, and I was really exited about the powerful “Elegant Builder” features, but last night when I upgraded from WordPress 3.4 to 3.5 It just broke! now the modules are broken, its a complete mess, I’m really worry about it, because It was perfect before.

    I really don’t want to do a wordpress downgrade cause I’m afraid I lose my database.

    Please, give me a hand with this.

    Keep the the great work.

    Thanks.

    • You need to keep your plugins and themes updated to their latest versions to ensure that there are no compatibility issues. Please update to version 2.2 of the Elegant Builder, which has been tested and updated for WP 3.5. The plugin was updated a week ago to address these upcoming issues.

  12. Upgrade went well, I had no issues with the new WP.

    Nice to see how fast you adapt to new WP versions.

  13. Guys I’m having some serious problem with Gleam theme and WP 3.5!

    The home page menu doesn’t work correctly!

    • Sorry for any trouble you are having. Please make sure that you are using the latest version of Gleam. If updating does not help, then open a ticket in our support forums so that our tech support team can fix the problem for you.

  14. Thank you Nick for your help, I’m going to try updating Elegant Builder as you said to its latest version.

    Thanks again.

  15. Good morning. I upgraded wordpress to version 3.5. Using the theme TheStyle (v3.3). Now I have a problem with the footer. If I insert a widget only okay, but if you insert more than one I do not stay in line but lined up vertically.
    Is there a solution?

    Alessio

  16. Updated to 3.5 and updated the Webly theme to the latest one. Having two problems at present. First is that Footer menu is showing up despite being set to blank. The second, and more important is that the Featured Slider is malfunctioning. There are error messages appearing and they build on top of each other. They are also more than the 3 “slides” being shown (though 4 of them are error messages of some sort).

    Any help will be greatly appreciated.

    Steve

    • We are not seeing any problems with the Webly theme and 3.5. Please make sure you are using the latest version of the theme, disable all of your plugins, and if the problem persists then please open a thread in our support forums so that our tech support team can assist you.

      • Did/do have the latest version of the Webly Theme. Looks like the problem is with the WordPress Jetpack plug-in so it is deactivated for now.

  17. Convertible does not functiion with WordPress 3.5!!

    • We have updated the theme to fix 3.5 compatibility issues. Please update to the latest version.

  18. WordPress 3.5 is the second major release for 2012 and is focused on improvements of existing features. I was waiting for some improvement in wordpress and here it is. Glad to see some really good features. thanks for sharing.

  19. Estore Theme has broken when switching to WP 3.5 it has made it so that the Admin section is not working, text editor, buttons etc…

    • Make sure you are using the latest version of the theme and that you disable all of your plugins. If you still experience problems, then please open a thread in our support forums so that we can assist you.

  20. I think this theme is broken under Word Press 3.5. The following javascript error is produced since the upgrade.

    Uncaught TypeError: Cannot call method 'indexOf' of null at line 80 in custom.js.

    • What theme are you referring to? Make sure that you are using the latest version of your themes and plugins. If you still experience problem, please open a thread in our support forums so that we can assist you.

  21. Is it just me or is anyone else having problems uploading featured images

  22. Actually i cant uploaded any media at all :-(

  23. All of your themes are inoperable (in the sense that they fire off unlimited numbers of processes) on new WordPress 3.5 Hostgator sites. I have had to discontinue all use of the themes on new my installs. For some reason they still work on old installs. Most sad…

    • Make sure you are using the latest version of the theme and that you disable all of your plugins. If you still experience problems, then please open a thread in our support forums so that we can better assist you.

  24. Hello, I purchased the complete theme package and uploaded them all to my website. About half of the previews work and install while the others show only x’s where the graphics should be and no theme preview. Does anyone know what is wrong here? The latest WordPress 3.5 is installed. Thanks.

    • If you need help, please open a thread in our support forums so that our tech support team can assist you.

  25. Hi,

    How can I update the theme without affecting the old changes ?

    Happy holidays

  26. since updating, I am not able to use my 4 scrollers on the home page and neither does my shortcode scroller work or show anymore. Not only that but my codes are validating incorrect with w3c saying I have closing tags where there are no opening yet in the text editor there are no such ‘s opening or closing. This is why I hate updating!!! No one in support seems to be fixing the issue

  27. My favorite part of WordPress 3.5 is the way it handles the images now. Uploading multi images was a total pain in the butt before.

  28. It looks like the last version of Convertible is not working in WordPress 3.5. It looks odd, and the structure in the landing page builder is broken. Is that possible? Do I need to install the Elegant Builder too?

    • The latest version should be working. If you are experiencing problems, please open a thread in our support forum so that our tech support team can assist you.

  29. Hi, I just updated to WordPress 3.5 and that created a lot of problems for my site that had the Gleam Theme installed. The menus don’t work; I can’t scroll on pages; etc. I read above that I should try to install the latest version of the gleam theme but it says “automatic upgrade unavailable for this theme.” SO how do i get the latest update (v1.9) and will that fix my problems? Thanks

    • You can log in to the member’s area to download the latest version. You will need to re-upload it manually as auto-updates are only available for themes in the free wp repository.

  30. I’ve been using WordPress for several years now and I can’t remember an upgrade that has so many positive features. I’m worried about updating some of my sites, but the ones I have upgraded have been worth the work!

  31. WordPress 3.5 is the second major release for 2012 and is focused on improvements of existing features. I was waiting for some improvement in wordpress and here it is. Glad to see some really good features. thanks for sharing.

  32. After I have updated to 3.5 then my SimplePress theme wont show the media library when I’m editing/creating a new page. I can upload but the library is just white? How can I fix this? – It says that the theme is up to date?

    Hope to hear from you.

    • If you need help, please open a thread in our support forums so that we can better assist you.

  33. Nice features added in new WordPress 3.5 version. Specially the media gallery section.

  34. this theme make me remember to orange juice, orange and vitamin C :). Actually its nice theme.

  35. The website mrenergyczar.com with the webly theme updated and WordPress 3.5.1 has a slider issue. With Firefox, Chrome and Internet Explorer you will see a continual loading circle. With Safari there is no loading circle but the text is dropped below the picture and hidden behind buttons. Please help?

  36. When I attempted to upgrade I kept getting an error message. I finally realized that I had to deactivate all my plug-ins. At least one of them was causing a problem with the update. Arghhhhh!

Leave a Reply

Your email address will not be published. Required fields are marked *

Current ye@r *

Join 253,319 Happy Customers And Get Access To Our Entire Collection Of 87 Beautiful Themes For The Price Of One

We offer a 30 Day Money Back Guarantee, so joining is risk-free!

Sign Up Today

Pin It on Pinterest

Shares
Share This